From 25bbca4a519d0b12dd1591698adee619ab59ef21 Mon Sep 17 00:00:00 2001 From: Mladen Milankovic Date: Thu, 29 Oct 2026 18:06:01 +0100 Subject: [PATCH] Update pylint to 4.1.3 and astroid to 4.3.4 pylint 3.3.1 has GHSA-22qq-2fwx-7p67, fixed in 4.0.9. Both packages now require Python 3.10 or later. Co-Authored-By: Claude Opus 5.5 --- dev-requirements.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/dev-requirements.txt b/dev-requirements.txt index 7127822..a1b5426 100644 --- a/dev-requirements.txt +++ b/dev-requirements.txt @@ -1,6 +1,6 @@ -i https://pypi.org/simple altgraph==0.17.5 -astroid==3.3.5; python_full_version >= '3.9.0' +astroid==4.3.4; python_full_version >= '3.10.0' colorama==0.4.6; sys_platform == 'win32' dill==0.4.1; python_version >= '3.11' iniconfig==2.3.1; python_version >= '3.7' @@ -14,7 +14,7 @@ platformdirs==4.13.5; python_version >= '3.8' pluggy==1.7.0; python_version >= '3.8' pyinstaller==6.22.3; python_version < '3.14' and python_version >= '3.8' pyinstaller-hooks-contrib==2026.9; python_version >= '3.8' -pylint==3.3.1; python_full_version >= '3.9.0' +pylint==4.1.3; python_full_version >= '3.10.0' pytest==9.1.1; python_version >= '3.8' pytest-pylint==0.21.0; python_version >= '3.7' pywin32-ctypes==0.2.3; sys_platform == 'win32'